Applies to AQTime 8.80, last modified on June 13, 2019

The General Preferences dialog is used to configure certain aspects of the profiling process and specify how to work with recently used projects. To call the dialog, select Options > Options from AQTime’s main menu and then choose the General > General Preferences group in the ensuing Options dialog.select Tools > Options from the main menu of Visual Studio and then choose the AQTime > General > General Preferences group in the ensuing Options dialog.select AQTime > Options from the main menu of Embarcadero RAD Studio.

The following options are available:

  • Project

    These options are available only if you use the AQTime stand-alone version:

    • At startup - Specifies what should be displayed each time you start AQTime. The following options are available:

      • Open Start Page - AQTime will display the Start Page Panel Start Page.

      • Open last project - AQTime will load the project you were last working on. Note that if no project is opened when you exit AQTime, no project will be loaded the next time you start AQTime.

      • Do nothing - AQTime will display an empty workspace.

    • Auto reload debug information - If this option is enabled, AQTime will automatically reload debug information for the modules that are included in your project when these modules are changed (for instance, when you recompile them in your development tool).

    • Number of recently used projects - Specifies the number of entries in the list of recently used projects, which are available in the File > Recent menu and on the Start Page. The value ranges from 1 to 24. The default value is 4.

  • Profiling

    • Show instrumentation progress - If this option is enabled, AQTime displays the progress bar when instrumenting the application code.

    • Exclude routines with no source info - Specifies if AQTime should ignore routines for which the debug info holds no information about the source files. If this option is enabled, these routines become invisible to AQTime services. They are not displayed in the Setup panel, they are not included in profiling tasks, etc. The option is ignored, if you check Entire .NET Code in the Setup panel. The All Project Modules box has no effect on this option.

    • Exclude standard source files - Specifies whether to profile source files, classes and routines of standard libraries that are embedded into the application by IDEs. For example, in Borland Delphi applications, these are the System, Sysutils, Classes, Controls and some other units. The units are filtered by their paths (Microsoft Visual Studio), or by their names (Borland Delphi, C++Builder, Microsoft Visual C++). This option can also be toggled using the Exclude Standard Source Files button on the Setup panel’s toolbar.

      Note: This option is supported only for native (unmanaged) and .NET applications.
    • Bypass ignore settings - If this option is on, AQTime ignores any settings made in the Ignore Files and Routines and Files to Ignore for Project dialogs.

  • Panels

    • Hexadecimal numbers prefix - The prefix of hexadecimal numbers displayed in the AQTime panels. Available values: 0x, $, &H.

  • Debugging Engine

    • Consider the browser to be a single process - This setting is needed if you profile script code or a Silverlight application running in a web browser, or when you profile some modules loaded to the web browser’s process. Modern web browsers can use several processes. In order for AQTime to be able to start profiling, it needs to know the browser’s process in which the code to be profiled is loaded. This setting specifies how AQTime determines this process:

      • If the setting is disabled (default), AQTime uses a notification, which the web browser sends. The notifications helps AQTime determine the needed process.

      • If the setting is enabled, AQTime “thinks” the browser has only one process (the process that was launched under AQTime).

      If the setting is enabled, AQTime profiles the browser process automatically, it does not wait for the moment when the browser loads the code or module to be profiled. If the setting is disabled, AQTime does not start profiling until it receives a notification from the browser.

      Note: If the setting is enabled but the web browser that hosts the script code you want to profile is actually running in the multiple-process mode, AQTime cannot detect the browser’s process that hosts the script code and no profiling results are generated. Disable the setting or switch the browser to the single-process mode (see Profiling Scripts - Prerequisites).

      By default, it is recommended to start profiling with the option disabled. This will work in most cases. You can enable the option only if AQTime is unable to profile modules loaded to the browser process. For complete information, see Profiling Browser-Hosted Code.

    • Get results at early finalization phase - By default, AQTime generates profiling results when the profiled application stops. If the profiled application does not perform finalization properly, the system terminates it and AQTime cannot generate results. Use this setting to command AQTime to generate results at an early finalization phase. This will help you work around the problem.

      Note, however, that AQTime will still attempt to generate results at the end of the application finalization. If both attempts succeed, you will get two result sets: the one generated at the beginning of finalization and the one generated at the end of finalization.

    • Profiled application runs in compatibility mode -  Some applications created  for earlier versions of the Windows operating system may work improperly on newer versions of the operating system. To make these applications work correctly, you can run them in the compatibility mode. This functionality is provided by the operating system. For some applications Windows activates the compatibility mode automatically. For others, you need to do this manually. You can enable the compatibility settings using the Properties dialog you invoke by choosing Properties form the context menu of the application's shortcut, or by using the Program Compatibility troubleshooter (see the Article ID: MSW700015 on Microsoft's web site).

      Applications that run in the compatibility mode are profiled in a special manner. You enable this option to "tell" AQTime that the profiled process should run in the compatibility mode and that it should work with this application in a special way.

      Note that this option may cause problems with service profiling, when working with AQTime via COM, when attaching to processes and in some other cases. It is not recommended to enable this option if you are not sure whether your application is working in the compatibility mode. We recommend that you consult our Support Team and enable this option only if they tell you to do this.

      For more information, see Profiling Applications Running in the Compatibility Mode.

    • Use extended debugger for managed code - Specifies whether to use an extended debugger. If the option is disabled, you will not see .NET events in the Event View panel. Also, if an exception occurs in the unmanaged code of the application being profiled, managed code will not be listed in the resulting call stack.

See Also

Options Dialog

Highlight search results