Print Preview Form

Applies to AQTime 8.81, last modified on April 19, 2021

The File submenu of AQTime’sVisual Studio’sBorland Developer Studio’s main menu includes the Print Preview item, which opens the Print Preview form. Within Print Preview, you can format the report for printing (including colors and background), set paper size and page formatting, choose printers and so forth.

Print Preview Form

The main view of the preview is page-oriented, and you can format your report interactively within it. The Print Preview form has one toolbar - Standard. Some toolbar options are also available on the context menu.

The toolbar includes a Close button. Print Preview is modal, so you must close it (not just minimize it) to return to the main AQTime window.

To print from Print Preview, you can select Print from of the Standard toolbar, or choose Print Dialog, or FilePrint, and click OK from the dialog once you are satisfied with your settings.

By default, the first button in the Standard toolbar () is the Report Designer button. This, or File > Design, offers a wealth of further formatting options. It is a good idea to look at the Designer before going to work to achieve elaborate formatting interactively from the main Print Preview form.

Some things you can do from Print Preview outside the Report Designer --

  • Change page margins: Either drag the margins on screen, or use Page Setup to set margins numerically, or use File > Page Setup.

  • Configure a report’s header and footer: Use the Header/Footer page of the Page Setup dialog.

  • Change the background color, fill pattern, shading or fill image (watermark) for the printed pages: Use Background Dialog button, or Format > Background.

  • Change the format of page numbers in your report: Select Page Numbering from the Format menu. See Page Number Format Dialog.
  • Change the date and time format of the report: Select Format > Date and Time from the form’s menu. See Date and Time Format Dialog.

  • Shrink a small report to fit a page: Use Fit to Page on the toolbar (or Format > Fit to Page in the menu) and play with the margins onscreen as your needs dictate. (Note: The only way to enlarge a report, is to modify the fonts in the Report Designer.)

  • Select what pages to print, how many copies, and the printer to output to: Select Print from the Standard toolbar, or File > Print.

  • Configure the main part of the form to your liking - zoom-button step increments, IntelliMouse support, margin-line color, and so on: Use File > Options to open the Options Dialog.

See Also

Print Preview - Background Palette Dialog
Print Preview - Options Dialog
Print Preview - Print Dialog
Print Preview - Zooming
Print Preview - Report Designer Dialog

Highlight search results