Applies to AQTime 8.80, last modified on June 13, 2019

The Event View panel offers several customizable options. You can check or change these options using the Event View Options dialog. To call it, do any of the following:

  • Select Options from the context menu of the Event View panel.

  • Select Options > Options from AQTime’s main menu. This will call the Options dialog. Event View Options belong to the Profiling Time group.

  • Select Options from the context menu of the Event View panel.

  • Right-click Event View in Visual Studio’s Solution Explorer and select Properties from the context menu.

  • Select Tools > Options from the main menu of Visual Studio and then select the AQTime > Profiling Time > Event View group in the ensuing Options dialog.

  • Select Options from the context menu of the Event View panel.

  • Select AQTime > Options from the main menu of Embarcadero RAD Studio. This will call the Options dialog. Event View Options belong to the Profiling Time group.

All options are divided into three large groups, General, Display Events in and Exceptions filter which you select on the left of the dialog.

General

This group contains options that specify how Event View handles events.

  • Clear on application start - Sets whether Event View will begin empty each time the profiled application is launched, that is, on each profile run. Else, it will keep events from previous runs.

  • Time format - Specifies what time format should be used to display time in the Time column of the panel. To specify the needed format, use date and time format specifiers.

    By default, the format string is hh:nn:ss:zzz, where hh stands for hours, nn - for minutes, ss - for seconds, and zzz - for milliseconds. Each letter corresponds to a digit.

  • Show stack address as RVA - This option specifies what format should be used to display stack addresses in events and messages. The address of each routine consists of two components: the base address of the module, which is the address where the module is loaded in memory, and the offset of the routine relative to this base address. The offset is also called a relative virtual address (RVA). If Show stack address as RVA is enabled, the event messages contain only relative virtual addresses. Otherwise, they contain the full routine addresses, that is, the base address + the offset. Note that the base address can only be determined after the module has been loaded into memory. The preferred loading address is used as the base one. The preferred loading address is specified in the header of the executable. To find it in AQTime, check the Optional header section on the PE Information page of the PE Reader panel.

  • Time from application start - If enabled, times shown in the Time column are elapsed times from application start. Else, they are system time.

  • Debug Events- Settings for the display on the Debug String events. None of them has effect unless you enable Show call stack.

    • Show all parents - The call stack may include functions for which there is no debug info. Typically these functions are located in pre-compiled libraries. If this option is enabled, the call stack will include these functions. Otherwise, they will be suppressed from the call stack display.

    • Show full module path - If it is enabled, the full path to modules is displayed in stack frames.

    • Generate dump on exception - If this setting is enabled, AQTime automatically generates a dump file when it detects an exception in the profiled application. The generated dump file contains information that helps you find the cause of the exception: memory data, the exception code and address, information about the application’s threads and loaded modules, and so on.

      The dumps are saved to the folder specified by the Dump folder setting (see below).

      Note: The dumps are not generated for those exceptions that AQTime filters out according to the Exception filter settings (see below) and does not log to the Event View panel.

      For detailed information on automatic dump generation, see Generating Dumps for Profiled Applications.

    • Dump folder - Specifies the folder to which AQTime will automatically save dumps when it detects an exception in the profiled application (see the description of the Generate dump on exception setting above). Note that the folder must exist; AQTime does not create it automatically.

    • Show call stack - This section contains options that specify whether AQTime traces the stack of function calls for the following debug events:

      • Module Loaded
      • Module Unloaded
      • Debug String
      • User Breakpoint
      • Process Suspended

      The Depth shown setting specifies the number of routines in the call stack. Default: 10.  0 means no tracing.

  • Exceptions - Settings for the display of exception events. None (except Active) has any effect unless Active is enabled.

    • Active - Enables exception logging. When enabled, exceptions are shown in Event View, as set by the suboptions below, and their time is counted in the function where they occur. Else, exceptions are neither logged as events nor counted as part of execution time.

    • Hide IsBadPtr exceptions - This option affects applications that use the IsBadReadPtr, IsBadWritePtr, IsBadCodePtr or IsBadStringPtr Windows API function. If the option is enabled, exceptions raised by these functions will not be logged to Event View. See Exceptions in the Event View Panel.

    • Show call stack - If it is enabled, the call stack will be traced for each exception and displayed in the Event View panel.

    • Depth shown - If Show call stack is on, this option specifies the number of traced routines in the stack. Default value: 10. 0 means no tracing.

    • Show all parents - The call stack may well include functions for which there is no debug info, typically from pre-compiled libraries. If this option is enabled, the call stack shown for exception events will include these functions. Else, they will be suppressed from the call stack display.

    • Max consecutive exceptions - Number of exception events uninterrupted by any other event, after which exception logging will be disabled until the next non-exception event. This saves profiling time during exception loops.

    • Show full module path - If it is enabled, the full path to modules is displayed in stack frames when an exception occurs.

Display events in

This group includes options that specify where AQTime outputs event and message flow.

  • Event View panel

    • Active - If this option is enabled, AQTime outputs events and messages to the Event View panel.

  • NT event log

    • Active - If this option is enabled, AQTime outputs events and messages to the Application Log section of the Event Viewer of Windows XP and later. To see the error log, open the Event Viewer component (Control Panel > Administrative Tools > Event Viewer) and select the Windows Logs > Application node on Windows Vista and later, or the Application node on Windows XP.

    • Event source name - Specifies the string that will be displayed in the Source column of the Event Viewer.

  • Text file

    • Active - If this option is enabled, AQTime writes the event flow to a text file.

    • File name - The name of the text file for output.

  • XML file

    • Active - If this option is enabled, AQTime writes events and messages to an .xml file.

    • File name - The name of the .xml file for output.

Exceptions filter

The settings in this group specify exceptions to be excluded from the Event View panel. This functionality helps you exclude unimportant issues from analysis and concentrate your efforts on critical exceptions.

The Exceptions filter page contains a list of Win32 exceptions to be excluded from analysis. The Event View panel will skip those exceptions that are added to the list and selected in this list. If an exception is not selected (its check box is clear) or if it is absent from the list, the Event View panel will log this exception.

By default, the list contains Win32 exceptions. You can add them to or exclude them from the filter by selecting or clearing the appropriate check box.

To add a new exception to the list:

  • Click Add. This will invoke the Add Exception dialog.

  • In the dialog:

    • Enter the code of the desired exception into the Code edit box.

    • In the Description box, type any descriptive text.

    • Click OK.

    The exception will be added to the list.

To remove an exception from the list:

  • Select the desired exception in the list.

  • Click Delete.

See Also

About the Event View Panel
Exceptions in the Event View Panel

Highlight search results