Unused VCL Units Profiler Tutorial: 1 - Generating Data

Applies to AQTime 8.81, last modified on November 27, 2020

When explaining how to work with the Unused VCL Units profiler, we will use a sample application, UnusedVCLUnitsDemo, which is installed along with AQTime. You can find it in the following folder:

<AQTime Samples>\Unmanaged\UnusedVCLUnits\  -  Borland Delphi

On Windows Vista and later, AQTime samples are located in the <Users>\Public\Documents\AQTime 8 Samples folder. On other operating systems, the samples reside in the <Documents and Settings>\All Users\Documents\AQTime 8 Samples folder.

To profile this example with AQTime, do the following:

  • Open the application in AQTime.

  • Select Unused VCL Units Profiler from the Profilers drop-down list on the Standard toolbar.

    Select Unused VCL Units Profiler from the Profilers drop-down list displayed in the AQTime menu of Microsoft Visual Studio.

    Select Unused VCL Units Profiler from the Current Profiler submenu displayed in the AQTime menu of Embarcadero RAD Studio.

  • Select Options > Options from AQTime’s main menu Select Tools > Options > AQTime from Visual Studio’s main menu Select AQTime > Options from Embarcadero RAD Studio’s main menu to display the Options dialog.

    In the dialog, select Profilers > Static Analysis > Unused VCL Units Profiler from the list on the left. Specify the version of the compiler that was used to build the sample in the Delphi version option.

  • Select Project > Search Directories from AQTime’s main menu.Select Project > Search Directories from Visual Studio’s main menu.Select AQTime > Search Directories from the main menu of Embarcadero RAD Studio. This will call the Project Search Directories dialog. In the dialog, specify the paths to the source code of standard VCL units. The easiest way to do this is to press Get Defaults and choose the appropriate compiler version from the drop-down list.

  • Click Run on the Standard toolbar.

    Select Run from Visual Studio’s AQTime menu, or press Visual Studio’s Run button while any of AQTime panels is active.

    Select Run With Profiling from Embarcadero RAD Studio’s AQTime menu.

  • Depending on the Show Again Flags options, AQTime may call the Profiler Options dialog. Make sure the Delphi version option corresponds to the compiler used to build the sample and click Run to start profiling.

  • Wait until the profiling results are obtained.

Note that there is no need to set up areas and triggers, since the profiler does not support them. Also, it is not necessary to check the state of the Enable/Disable Profiling item, because the profiler is static and does not launch your application.

In the next two steps, we will analyze the profiling results.

Prev     Next

See Also

Unused VCL Units Profiler - Overview

Highlight search results