Applies to TestComplete 14.70, last modified on October 20, 2020

This topic provides information on tasks you can accomplish in the XMLCheckpoint Element editor:

Changing Data Source
  • In the editor, click Edit.

  • In the ensuing Select XML Data Source dialog, specify the file name or URL from which TestComplete will load data.

Adding Nodes
  • On the Tree View page of the editor, select a node to which you want to add a child or sibling element.

  • Click the appropriate menu on the Tree View toolbar.

  • Select the position of the new node relative of the currently selected node by clicking Before, After or Child.

  • The new node will be added to the tree structure. Specify the name of the new node.

Renaming Nodes
  • Select the desired node’s name in the tree.

  • Click the node name or press F2. This will activate the in-place editor.

  • Enter a new name into the in-place editor. Press Enter to confirm the changes or Esc to cancel them.

Modifying Node Data
  • Select the cell containing the desired node’s value.

  • Click the node name or press F2. This will activate the in-place editor.

  • Enter the desired value into the in-place editor. Use Ctrl+Enter to enter a line break.

  • To confirm changes, press Enter. To cancel changes, press Esc.

Changing Node Position

To change the node’s location:

  • Select the desired node.

  • Move the selected node to the desired position in the tree. When moving a node, keep the cursor over the node names rather than the icons.

– or –

  • Select the desired node.

  • Choose Edit > Cut from the TestComplete main menu. This will remove the node from the tree and copy it to the clipboard. If the node has child nodes, they will also be removed and copied.

  • Select the node that will be the parent for a new node.

  • Choose Edit > Paste from the TestComplete main menu to insert the copied node into the new position. If the copied node has child nodes, they are also inserted.

Copying Nodes to Other Locations
  • Select the desired node in the tree.

  • Press Ctrl and hold it pressed while dragging the node to the desired location, keeping the cursor over the node’s names rather than the icons.

– or –

  • Select the desired node in the tree.

  • Choose Edit > Copy from TestComplete’ main menu. This will copy the selected node along with its child nodes to the clipboard.

  • Select the node that will be the parent.

  • Choose Edit > Paste from the TestComplete main menu to insert the copied node into the new position.

A node is copied along with its child nodes.

Deleting Nodes
  • Select the desired node in the tree.

  • Press Del.

You can also delete the selected node by choosing Edit > Delete from the TestComplete main menu.

If the selected node has child nodes, they are also deleted.

Undoing or Redoing Changes

To undo or redo changes made to the XML data, use the Edit > Undo and Edit > Redo items of the TestComplete main menu.

Saving Changes

To save changes made to the XML document and comparison options in the editor, select File > Save from the TestComplete main menu.

To close the editor without saving changes, close the editor’s tab and answer “No” when TestComplete asks you whether to save changes.

See Also

About XMLCheckpoint Element Editor
About XML Collection

Highlight search results