Applies to TestComplete 14.70, last modified on October 26, 2020

Description

Use the InstrumentedWithSupportedVersion property to check whether the tested application is prepared for testing with the current version of TestComplete.

Declaration

AndroidTestedAppObj.InstrumentedWithSupportedVersion

Read-Only Property Boolean
AndroidTestedAppObj An expression, variable or parameter that specifies a reference to an AndroidTestedApp object

Applies To

The property is applied to the following object:

Property Value

True if the application can be tested with the current version of TestComplete; false otherwise.

Example

The code below checks if your application is already instrumented:

JavaScript, JScript

if (!AndroidTestedApp.Instrumented)
{
  // Instrument the application
}

if (AndroidTestedApp.InstrumentedWithSupportedVersion)
{
  // Launch the application
}
else
{
  // Post an error to the log
}

Python

if not AndroidTestedApp.Instrumented:
  # Instrument the application

if AndroidTestedApp.InstrumentedWithSupportedVersion:
  # Launch the application
else:
  # Post an error to the log

VBScript

If not AndroidTestedApp.Instrumented Then
  ' Instrument the application
End If

If AndroidTestedApp.InstrumentedWithSupportedVersion Then
  ' Launch the application
Else
  ' Post an error to the log
End If

DelphiScript

if not AndroidTestedApp.Instrumented then
begin
  // Instrument the application
end;

if AndroidTestedApp.InstrumentedWithSupportedVersion then
begin
  // Launch the application
end
else
begin
  // Post an error to the log
end;

C++Script, C#Script

if (!AndroidTestedApp["Instrumented"])
{
  // Instrument the application
}

if (AndroidTestedApp["InstrumentedWithSupportedVersion"])
{
  // Launch the application
}
else
{
  // Post an error to the log
}

See Also

AndroidTestedApp Object
About Tested Android Applications

Highlight search results