Print Preview Form

Applies to TestComplete 14.93, last modified on September 27, 2021

You use the Print Preview form to format a report for printing (including colors and background), set paper size and page formatting, choose printers and so on.

You can call this form from the test results and from the Code Editor.

To call it from the test results:

  1. Open the needed test log or summary report.

  2. Select File > Print Preview from the TestComplete main menu.

– or –

  1. Open the needed test log or summary report.

  2. Right-click somewhere in the page and then click  Print Preview .

To call it from the Code Editor:

  1. Open the Code Editor.

  2. (Optional.) Select the text you want to print with the mouse cursor. If text is not selected, then the whole text of the unit will be printed.

  3. Select File > Print Preview from the TestComplete main menu.

Note: The view of the form is different for panels that contain HTML content (for example, Summary and Details). For such panels, the Print Preview form uses the built-in component of Internet Explorer installed on your machine. For more information on this Print Preview form, see the documentation for your Internet Explorer version.

The main view of the preview provided by TestComplete is page-oriented, and you can format your report interactively within it. The Print Preview form only has the Standard toolbar that contains an item that specifies the report viewing mode and calls a dialog where you can configure the page size, layout and other report settings. Some toolbar options are also available on the context (right-click) menu.

The toolbar includes a Close button. Print Preview is modal, so you must close it (not just minimize it) to return to the main TestComplete window.

To print from Print Preview, you can select Print from of the Standard toolbar, or choose Print Dialog, or File > Print, and click OK from the dialog once you are satisfied with your settings.

You can do any of the following from the Print Preview:

  • Change page margins - Either drag the margins on screen, or use  Page Setup to set margins numerically, or use File > Page Setup.

  • Export test results to a .pdf file - Either click Export To PDF on the form toolbar or select File > Export To PDF from the form main menu.

  • Use the Header/Footer page of the Page Setup dialog to create and configure a report’s header and footer.

  • Select Format > Page Numbering from the form menu to change the format of page numbers in your report. See Page Number Format Dialog for more information.

  • Select Format > Date and Time from the form menu to change the date and time format of the report. See Date and Time Format Dialog for more information.

  • Use the  Fit To Page option to adjust the margins onscreen as needed to shrink the report so that it fits on the page.

  • Select what pages to print, how many copies, and the desired printer for the output: Select  Print from the Standard toolbar, or File > Print.

  • Configure the main part of the form by using zoom button step increments, IntelliMouse support, margin-line color and so on: Use File > Options to open the Options dialog.

See Also

Print Preview - Options Dialog
Print Preview - Print Dialog
Print Preview - Zooming

Highlight search results