Importing and Exporting Projects

Applies to ReadyAPI 3.5, last modified on January 19, 2021

Importing is the process of opening existing project files and adding them to a workspace.

Import a local project

Local projects are stored on the same computer as ReadyAPI. There are several ways to import the project depending on how you store it.

To import a project file:

  1. Select File > Import Project.

  2. Specify the .xml project file.

  3. Click Open.

To import a composite project:

  1. Select File > Import Composite Project.

  2. Select the root folder of the composite project.

  3. Click Select Folder.

To import a packed project:

  1. Select File > Import Packed Project.

  2. Specify the .zip archive with the packed project.

    The packed project should not be in the composite format and the project .xml file should end with -soapui-project.xml.
  3. Click Open.

  4. Specify the folder to unpack the project to.

Import remote projects

You can import projects using the HTTP protocol. This feature also allows you to publish projects (like tutorials, demonstrations or bug-reports) on a website, and then import them on a different computer.

To import a remote project:

  1. Select File > Import Remote Project.

  2. Specify the project file’s URL to import the project from a resource.

    It is impossible to save the project file back to the web site, so ReadyAPI saves the changes to a local copy.
  3. Click OK.

Resolve import issues

When you import a project or test case, ReadyAPI automatically checks whether it is consistent and has all necessary external dependencies available. In other words, ReadyAPI resolves a project.

During the resolving process, you can check whether the resources in your project or test case have unique identifiers.

You can also resolve a project manually. To do this, right-click the project in the Navigator and select Resolve.

If your project contains errors, the Resolve dialog appears. You can resolve the errors listed in the dialog by assigning the required values.

The Resolve Dialog

Click the image to enlarge it.

To open an item, double-click it on the list. In the corresponding editor, resolve the issue:

  1. Select an appropriate action from the drop-down menu to the right of each item.

  2. Enter parameters or values as needed.

  3. Click OK.

Reload projects

You can reload a project in the workspace. When you reload the project, ReadyAPI closes this project, discards the changes, and opens the project file again.

To reload a project:

  1. Select a project in the Navigator.

  2. Right-click it and select Reload.

  3. Select the .xml project file you want to reload.

  4. Click Open.

You can also click Project > Reload and then select the project file you need.

Export projects

When you export a project, ReadyAPI packs the project into a zip package. Besides the project file, the package will contain all external dependencies, such as external data sources, certificates, or attachments. It is usefull, when you send your project or if want to run the project in TestEngine.

To export a project:

  1. Select a project in the Navigator.

  2. Right-click it and select Export.

  3. Select a folder where you want to save a zip package.

See Also

Creating Projects
Project Management

Highlight search results