Applies to Collaborator 12.2, last modified on October 31, 2019

The following table describes which versions of Java environment are supported by different versions of Collaborator:

Oracle JDK 6

Oracle JDK 7

Oracle JDK 8

Oracle JDK 9

OpenJDK 11 / Oracle JDK 11

RTC 4.x install with Java 6

RTC 5.x install with Java 6

RTC 6.x install with Java 6

RTC 6.x install with Java 7

RTC 6.x install with Java 8

Eclipse running Java 6

Eclipse running Java 7

Eclipse running Java 8

Collaborator Server 12.0 and Newer

No

No

Yes+

Yes

Yes

No

No

No

No

Yes

NA

NA

NA

Collaborator Server 11.3 - 11.5.x

No

No

Yes+

Yes

No

Yes

Yes

Yes

Yes

No

NA

NA

NA

Collaborator Server 11.0-11.2

No

Yes+

Yes

No

No

Yes

Yes

Yes

Yes

No

NA

NA

NA

Collaborator Server 9.x-10.x

No

Yes+

Yes

No

No

Yes

Yes

Yes

Yes

No

NA

NA

NA

Collaborator Server 8.5.x

No

Yes+

No

No

No

Yes

Yes

No

No

No

NA

NA

NA

Collaborator Server 8.0 - 8.4.x

Yes+

Yes

No

No

No

Yes

Yes

No

No

No

NA

NA

NA

Collaborator Server 7.x

Yes+

No

No

No

No

Yes

Yes

No

No

No

NA

NA

NA

Collaborator Server 6.x

Yes+

No

No

No

No

No

No

No

No

No

NA

NA

NA

Collaborator Client 12.0 and Newer

No

No

Yes+

Yes

Yes

NA

NA

NA

NA

NA

NA

NA

NA

Collaborator Client 11.3 - 11.5.x

No

No

Yes+

Yes

No

NA

NA

NA

NA

NA

NA

NA

NA

Collaborator Client 11.0-11.2

No

Yes+

Yes

No

No

NA

NA

NA

NA

NA

NA

NA

NA

Collaborator Client 9.x-10.x

No

Yes+

Yes

No

No

NA

NA

NA

NA

NA

NA

NA

NA

Collaborator Client 8.5.x

No

Yes+

No

No

No

NA

NA

NA

NA

NA

NA

NA

NA

Collaborator Client 8.0 - 8.4.x

Yes+

Yes

No

No

No

NA

NA

NA

NA

NA

NA

NA

NA

Collaborator Client 7.x

Yes+

No

No

No

No

NA

NA

NA

NA

NA

NA

NA

NA

Collaborator Client 6.x

Yes+

No

No

No

No

NA

NA

NA

NA

NA

NA

NA

NA

Collaborator Eclipse plugin 12.0 and Newer

No

No

Yes+

Yes

Yes

No

No

No

No

Yes

No

No

Yes

Collaborator Eclipse plugin 11.3 - 11.5.x

No

Yes+

Yes+

Yes

Yes

No

No

No

Yes

No

No

Yes

Yes

Collaborator Eclipse plugin 11.0-11.2

No

Yes+

Yes

No

No

No

No

No

Yes

No

No

Yes

No

Collaborator Eclipse plugin 9.x-10.x

No

Yes+

Yes

No

No

No

No

No

No

No

No

Yes

No

Collaborator Eclipse plugin 8.5.x

No

Yes+

No

No

No

No

No

No

No

No

No

Yes

No

Collaborator Eclipse plugin 8.0 - 8.4.x

Yes+

Yes

No

No

No

Yes

Yes

Yes

No

No

Yes

Yes

No

Collaborator Eclipse plugin 7.x

Yes+

No

No

No

No

Yes

Yes

No

No

No

Yes

No

No

Collaborator Eclipse plugin 6.x

Yes+

No

No

No

No

No

No

No

No

No

No

No

No

Notes

  • In table above, the "Yes+" means that the given version of Collaborator was built using the given version of Java environment.
  • OpenJDK 11 is recommended, Oracle JRE/JDK 8, 9, or 11 might work as well.
  • On systems with multiple JREs installed, it may be necessary to specify to the installer which JRE should be used for Collaborator. On Windows platforms, running the installer with the -manual argument will suppress the JRE search and cause the installer to prompt for the JRE location (specifically, java.exe). On Unix platforms, you can specify the JRE location by setting the INSTALL4J_JAVA_HOME_OVERRIDE environment variable to the JAVA_HOME value.

See Also

Collaborator Server: System Requirements
Server Technical Specification
Java VM Options

Highlight search results