Applies to AQtime 8.71, last modified on December 5, 2018

Creating AQtime Projects

To create a blank project in AQtime, do any of the following:

  • Select File > New Project from AQtime’s main menu.

  • Click Create a New Project on the Start Page.

After that, you can specify the application modules you want to profile. To learn how to do this, see Selecting Applications and Modules to Profile.

To create a new AQtime project:

  • Select File > New > Project from Visual Studio’s menu, press the New Project button on the Start page or select AQtime > Add AQtime Project from Visual Studio’s menu. This will call the New Project dialog.

  • In the dialog:

    • Select AQtime Projects from the list on the left of the dialog and then click AQtime Project on the right.

    • Specify the project name, location and solution.

  • Press OK.

Visual Studio will create a new AQtime project and display its contents in the Solution Explorer.

In Embarcadero RAD Studio, AQtime projects (.aqt files) are part of the AQtime project groups (.bdsproj files), which are simply containers for several AQtime projects. Before creating a new AQtime project you must first create and open an AQtime project group to which this project will belong.

To create a new AQtime project group:

  • Right-click the root element in the Project Manager panel and select Add New Project from the context menu, or select File > New > Other or Project > Add New Project from RAD Studio’s menu. This will call the New Items dialog.

  • In the dialog, select Profiling from the list on the left of the dialog, click AQtime Project Group on the right and click OK.

RAD Studio will create a new AQtime project group and display its contents in the Project Manager.

To create a new AQtime project in the opened AQtime project group:

  • Select File > New > Other from RAD Studio’s menu. This will call the New Items dialog.

  • In the dialog, select Profiling from the list on the left of the dialog, click AQtime Project Module on the right and click OK.

RAD Studio will add a new AQtime project to the opened AQtime project group and display its contents in the Project Manager.

Saving AQtime Projects

To save your new AQtime project, select File > Save from AQtime’s main menu.To save your new AQtime project, select File > Save from Visual Studio’s main menu.To save your new AQtime project, select File > Save from RAD Studio’s main menu. This will open the standard Save File dialog where you can specify the project file name. If you create a new project and do not save it, the results and profiling configuration will be lost upon closing the project. However, after you have saved a project to a file, the results and changes you make to the profiling configuration will be saved automatically (AQtime saves them upon closing the project or after you select the File > Save menu item). The files that store profiling results reside in the project_name_Results subfolder of the project folder.

Opening Existing AQtime Projects

To open an existing project in AQtime, select File > Open Project:

Upon selecting this menu item, AQtime will display the standard Open File dialog where you can select the desired AQtime project file name. Once your project is open in AQtime, you can see a list of all object modules and their routines in the left-hand pane of the Setup panel:

You can open an existing AQtime project in Visual Studio in the same manner as you open any other Visual Studio project: just select File > Open > Project\Solution:

This will call the standard Open File dialog where you can select the desired AQtime project file name. After you open the project, you can see a list of all object modules and their routines in the left-hand pane of the Setup panel:

You can open an existing AQtime project in RAD Studio in the same manner as you open any other RAD Studio project: just select File > Open Project:

This will call the standard Open File dialog where you can select the desired AQtime project file name. After you open the project, you can see a list of all object modules and their routines in the left-hand pane of the Setup panel:

See Also

Selecting Applications and Modules to Profile

Highlight search results